ESA: Online Runner Tech Setup Guide

Page 1/16

ESA: Online Runner Tech Setup
Guide
Written by zoton2, version 6 (last updated 2020/07/29)

>>> Even if you have done a run before for us, please read this
guide again as things may have changed! <<<
For runners streaming to us for online marathons, we have a specific setup we want you to use, that helps the
tech team mix/adjust audio better, and also have a layout for your visual sources that works for our stream, for
an overall improved experience for the viewers.
The aim of this guide is to set you up so that you are sending us 4 audio channels (1 & 2 Game Audio,
3 Microphone, 4 Discord), and using our templates so your camera/game are in the correct places. If
you can reach this solution on your own without the guide (for example, the GoXLR already does the
same type of thing), that is also acceptable, but we are aware lots of you won’t know how to do this,
hence the guide.
From following this guide, you will be...
● streaming to Twitch, either on your own account, or an alternative account of your choosing (inform
tech if this is the case), and
● using a simple virtual audio cable setup using “VB-Audio VoiceMeeter Banana” (if needed), and a
custom built, portable version of “Open Broadcaster Software” (OBS).
This guide assumes you are using Windows 10. If using an earlier version it should work and be similar, but
you may need to enquire with tech. Any other Operating Systems may need some different setup.
We have attempted to write this guide to help you set this up correctly. If you are stuck or have any issues we
do not cover, please inform tech! (We can also use your help to update this guide for others too!)
Sorry if this guide appears to be long, but do hang in there, and it is overall very simple for most users.
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Audio Splitting Setup
>>> CONSOLE RUNNERS, STOP AND READ <<<
If you run on console, your audio usually comes through its own source in OBS and you do NOT listen
to your game via your PC, you can skip this part and go to the Streaming Setup part!
For our audio setup to work to help us easily adjust audio levels on the tech’s end, you need to do a little bit of
setup beforehand. We need everyone to do this even if you think you don’t need every part of it, just to make
the tech crew’s lives easier!
If you already have a copy of VB-Audio VoiceMeeter Banana (or Potato, as it includes the same
software/virtual audio cables), feel free to skip to step 4 of this, although we do advise that you are
sure the install is up to date.
1. Download the installer for “VB-Audio VoiceMeeter Banana” from
https://download.vb-audio.com/Download_CABLE/VoicemeeterProSetup.exe

>>> You may appear to lose sound during the next few steps, but this is
normal so don’t panic, as it is no longer by default being pushed through
your regular audio device. <<<
2. Run the installer and click the big “Install” button in the new window:

3. Once the install is done, you will be prompted to reboot, so do this.
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4. The installer should set the Windows audio output device to one of its own, although we advise you
double check this. The easiest way to do this on Windows 10: search in the Start Menu for “sound
settings” and in Sound settings, select the output device at the top.
The output device we need is “VoiceMeeter Aux Input (VB-Audio VoiceMeeter AUX VAIO)”:

If you usually have to adjust audio for your game in Windows audio mixer, you will need to do
this again with the new audio output device. Obviously at this part you will not be hearing
anything, but you may need to do this later.
The installer also likes to set the input device to their one, which we do not care about, so feel free to
change it just below the above setting:
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5. Open up the Discord desktop application and access the “User Settings” by clicking on the cog in the
lower left, near your username, and then in the settings window, go to “Voice & Video” :

Then, select “VoiceMeeter Input (VB-Audio VoiceMeeter VAIO)” in the “Output Device” dropdown.
Double check the device you have selected is the one named here, and not the same one you
selected earlier in Windows; note the lack of the word “Aux” in this one. We also advise to check
the “Input Device” is correct if you need to set it here, and that the “Output Volume” is set to 100%:

This is the audio splitting setup done! You will still not be able to hear anything but this is where we solve that
issue. There are several ways to do this, a few we have documented in this guide (click on the links to jump to
that part of the guide):
●
●
●
●

Using the “Voicemeeter Banana” program: easiest, but needs you to have their application open.
Using the built-in Windows feature: slightly harder to set up, but needs no applications open.
Using the monitoring feature in OBS: needs OBS open, but is reported to have less delay.
Using another program (supplied with VAC): this is more advanced, only try if you really need less
delay!

Before and after your marathon run, feel free to set back your default audio device in
Windows/Discord, which will return you back to how you had it before.
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Audio Monitoring: Voicemeeter Banana
This is probably the easiest option, but also needs you to keep an application open and may have too high of a
delay for your use.
1. Open the “Voicemeeter Banana” program, which can be found in your Start Menu (search for it, using
this name exactly, there are 2 applications that start with “Voicemeeter” so double check it’s the correct
one). You should see in the top right there is some flashing text asking you to select your main output
device:

2. Click on the “A1” button shown above and then select your normal output device, for example your
headphones, but make sure it begins with “MME”, otherwise you may suffer audio issues.
After this, you should be able to hear your desktop audio and your Discord audio via “Voicemeeter Banana” , as
long as it is kept open. If you do not wish to have to do this, see the next part of the guide below.
For previous users of “VB-Audio VoiceMeeter Banana”: We advise you to reset the settings so they are
correct for our setup. You can do this by clicking “Menu” > “Reset Settings (Re-Initialization)” . If you wish to
keep your old settings, these can be backed up by using “Menu” > “Save Settings…” and then be loaded back
in in the future with “Menu” > “Load Settings…”.

ESA: Online Runner Tech Setup Guide

Page 6/16

Audio Monitoring: Windows
It is possible to monitor the virtual audio cables via Windows itself, although slightly harder than just opening
“Voicemeeter Banana” , but does not require you to have any applications open.
Make sure that “Voicemeeter Banana” is closed, otherwise this functionality may not work.
1. Go to the “Sound” control panel in Windows. The easiest way to do this on Windows 10 is to right-click
the volume icon in your taskbar, and then click “Sounds” .
2. In the new window that appears, go to the “Recording” tab, and look for “VoiceMeeter Aux Output” and
double-click on it to access it’s properties.
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3. In the new window, go to the “Listen” tab. Tick the “Listen to this device” option, then in the “Playback
through this device” dropdown, select your normal output device (your headphones for example). Then
click OK.

4. Repeat the last 2 steps, but this time with “VoiceMeeter Output” in the list instead. You can then also
press OK on the “Sound” control panel.
After this, you should be able to hear your desktop audio and your Discord audio at any time without having
any applications open. You may have some audio delay though, and if there is too much, try the OBS audio
monitoring guide below instead.
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Audio Monitoring: OBS
Another option to monitor your audio besides the others mentioned is via OBS itself, although you will be
required to have OBS open to hear it, although some users have reported this has a lower delay than other
methods.
For this step you require our copy of OBS set up and running, so go and follow Streaming Setup, then come
back here and continue.
If you just followed the “Audio Monitoring: Windows” guide and are now trying this one instead, make
sure you disable the Windows audio monitoring by doing the steps in that guide and unticking “Listen
to this device”.
1. Open up our supplied copy of “Open Broadcaster Software” (OBS), using “esa-obs.cmd” . In there, go to
“File” > “Settings” and then select the “Audio” tab on the left hand side. Under the “Advanced” section,
change the “Monitoring Device” to your normal output device (your headphones for example). Then
click OK to close the settings:

2. Back in the main OBS window, go to “Edit” > “Advanced Audio Properties”, and then in the new
window:
a. find the “Audio Monitoring” dropdown for “Game Input” and set it to “Monitor and Output”
b. find the “Audio Monitoring” dropdown for “Discord Input” and set it to “Monitor and Output”
c. close the window

After this, you should be able to hear your desktop audio and your Discord audio via OBS, as long as it is kept
open.
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Audio Monitoring: VAC Audio Repeater (advanced)
If none of the other options have a low enough delay for you, you can attempt to use another program with
more advanced settings you can toggle to try and get it as low as possible. This actually uses a program
supplied with another virtual audio cable program, but we won’t be using that virtual audio cable, only a
program supplied with it.
If you just followed the “Audio Monitoring: Windows” guide and are now trying this one instead, make
sure you disable the Windows audio monitoring by doing the steps in that guide and unticking “Listen
to this device”. Also make sure that “Voicemeeter Banana” is closed, otherwise this functionality may
not work.
1. Download the VAC trial ZIP, the currently available version is available from
https://software.muzychenko.net/trials/vac464.zip
(there may be a more up to date version available at https://vac.muzychenko.net/en/download.htm)
and then extract the files to any location on your computer (we recommended your desktop, as long as
it’s not too messy!)
2. Inside of the newly extracted folder, open the folder named “x64” , and then inside of this, run the
“audiorepeater.exe” file.
3. Under “Wave In” , select “VoiceMeeter Aux Output” , and under “Wave Out”, select your normal output
device, then click the “Start” button, at which point audio should be coming though. You can try different
delay amounts by clicking “Stop”, changing the value in the “Total buffer (ms)” dropdown, then trying
again, and see what the lowest value your PC can handle is (hint: check the overflow/underflow count,
it should be blank or at least a very low number):

4. If you need to use this solution for both game audio and Discord audio, open another copy of
“audiorepeater.exe” and repeat step 3, but select “VoiceMeeter Output” i nstead.
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Streaming Setup
Because of the changes we use to send multiple audio channels to us from you, we must use a custom build of
“Open Broadcaster Software” (OBS). We have it set up in a way that means it shares no settings with your
regular install (if you normally use OBS) so do not worry about it changing anything for your usual streaming).

>>> Even if you normally use OBS or a fork such as StreamLabs OBS (SLOBS),
you must follow this guide and use our copy, for reasons already stated! <<<
1. Download our custom build of “Open Broadcaster Software” (OBS) from
https://oromit.de/files/ESA-OBS.zip and extract the files to any location on your computer (we
recommended your desktop, as long as it’s not too messy!).
2. Navigate to the extracted directory and you should see a directory listing like this:

3. Run “esa-obs.cmd” to open this copy of OBS; this is how you will open it in the future too, so remember
this for when it’s your time to run!
If Windows gives you an error along the lines of “VCRUNTIME140_1.dll was not found”, this
means you need to install the Microsoft Visual C++ Redistributable, available here
(vc_redist.x64.exe) :
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
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5. This is what the window should look like when you first open it (the selected scene may be different, but
they are all identical besides a template image):

On the far bottom left, you have all the scenes available for you to use for your run. If none of these are
applicable for your run, please inform tech! You can click through them and give them a moment to
load, to see what each one looks like.
To the right of this you have the sources, and 3 audio based sources have already been set up for you,
please do not delete these as they are needed later in the guide!
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If you didn’t have to follow the “Audio Splitting Setup” portion of this guide, skip to step 7!
6. Open the properties for the “Game Input” source (most easily done by double clicking on it in the
“Sources” list) and in the dropdown presented, select
“VoiceMeeter Aux Input (VB-Audio VoiceMeeter AUX VAIO)” then click OK:

7. Open the properties for the “Discord Input” source (most easily done by double clicking on it in the
“Sources” list) and in the dropdown presented, select
a. If you followed the “Audio Splitting Setup” guide: “VoiceMeeter Input (VB-Audio
VoiceMeeter AUX VAIO)”
b. If you didn’t need to follow the “Audio Splitting Setup” guide: either select your normal
sound output, or leave on “Default” if you are not sure.
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8. Now do the same with the “Microphone Input” source, but here you will need to select your microphone.
If you use the one already defaulted in Windows and do not know the correct one, you can leave this on
default although we suggest actually setting it:

9. Now, as long as audio is being sent through these devices, you should see the meters in the mixer
moving (ignore “Game Input” if you did not follow that step above):
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10. Select the appropriate scene that you need for your run, where alongside the audio sources you should
also see a template for you to use to position your sources. Add your camera and your game capture
into OBS in the usual way and make sure they are at the bottom o
 f the “Sources” list (we assume you
know how to use OBS, if not please ask tech). If you are doing a run with 2 players and using one of
the “2 Player” layouts, please only use the side that you have been told to by tech. You should end up
with something like this:

11. If the last step added an extra source in the “Audio Mixer” for your camera’s microphone please make
sure it is muted:
If you didn’t have to follow the “Audio Splitting Setup” portion of this guide, mute “Game Input”
in here as well, as the audio will come through the Video Capture Device for your capture card
instead.
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12. In OBS, go to “File” > “Settings” and then select the “Stream” tab on the left hand side. Here you must
enter your stream key for Twitch, which can be easily found by clicking on the “Get Stream Key” button:

Next, go to the “Output” tab and adjust the bitrate if you need a lower
bitrate to stream to Twitch consistently:
Another thing you may need to change is the “Encoder” option, if you use your GPU’s encoder, such as
NVIDIA NVENC, as by default it is set to x264.
We also advise you go into the “Recording” tab and set up a recording location and also to locally
record your run, as if you need this for leaderboard proof in the future (if you happen to get a personal
best) you will need a video to properly mix the audio from, as our setup will mess with the audio regular
viewers hear on the Twitch player.
If needed, you can also go to the “Video” tab and change the FPS value and “Output (Scaled)
Resolution” if needed for you to stream at a decent quality.
If you need to change any other settings in OBS you are not sure about, please ask tech!
After this, make sure you click “OK” at the bottom left to save the settings!
If you had to follow this guide before doing the Audio Monitoring: OBS portion, you can return there
now. If not, continue on.
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Final Words
Your audio and streaming setups are now ready for you to stream your run! Just remember, if you close these
applications after setup or change the default audio devices, this is what you need to do just before your run:
●

If you needed to follow the “Audio Splitting Setup” portion of the guide:
○ Set Windows audio output device to “VoiceMeeter Aux Input (VB-Audio VoiceMeeter AUX
VAIO)”
○ Set Discord output device to “VoiceMeeter Input (VB-Audio VoiceMeeter VAIO)”
○ Open “Voicemeeter Banana” f rom your Start Menu, if applicable.

●

Open our custom OBS, by running “esa-obs.cmd” f rom the extracted folder.

You will also need to have Discord open and be in a voice channel, although these are not covered by this
guide.

